Soru Bunun anlamı nedir: paket önceliği korumaları nedeniyle hariç tutulan paketler


Yum ile güncellenirken aşağıdaki mesajı alıyorum:

yum update
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * atomic: www7.atomicorp.com
 * base: mirror.de.leaseweb.net
 * extras: mirror.de.leaseweb.net
 * updates: mirror.de.leaseweb.net
118 packages excluded due to repository priority protections
Setting up Update Process
No Packages marked for Update

Bu ne anlama geliyor ? Bu paketler nasıl kurulur?


54
2017-09-17 09:27


Menşei




Cevaplar:


Bazı paketler birden fazla depo tarafından tutulur. priorities eklenti, diğer reposlardan çift girişler hariç, en yüksek önceliğe sahip depodan paketleri seçer.


33
2017-09-17 09:53





Anladığım kadarıyla, bu hata priorities Pawel tarafından belirtildiği gibi eklenti.

2009 yılında belirtilen yumunun bakıcısı İnsanların kullanmadığını umduğunu priorities. Öncelikleri eklentiyi devre dışı bırakmak için düzenle /etc/yum/pluginconf.d/priorities.conf ve set enabled = 0. Bu değişiklikten sonra, bir sonraki sefer yum updateÖncelikli koruma almamalısınız.


47
2018-06-26 17:33



Sadece bunu kabul etmek için giriş yaptım. Öncelik ayarı etkinleştirildiği için openssh'im en son sürüme güncellenmedi. Bu bana yardımcı oldu. Teşekkürler! - manish_s
Evet, 'set enabled =' benim için çalıştı. Etkilenen paketlerin adları ve geldikleri depolar gibi yum'dan daha fazla bilgi almak hoş olurdu. (Bu ayrı bir soru mu?) - bobgus
bir yum erase yum-plugin-priorities ayrıca çalışır. - mbirth
Ayrıca eklentiyi de devre dışı bırakabilirsiniz. yumbu satırın komut satırı: --disableplugin=priorities - KJH


Öncelikli korumalardan dolayı hangi paketlerin hariç tutulduğunu öğrenmek isterseniz

yum list updates -d3

23
2018-04-23 16:45