Soru PhpMyAdmin (ubuntu lambasında): Şifre olmadan giriş yapmak, konfigürasyona göre yasaklanmıştır (bkz. AllowNoPassword).


My mysql password = '' PhpMyAdmin'e (Ubuntu 10.04 lambada) giriş yapmaya çalışıyorum ve hata alıyorum:   Şifre olmadan giriş yapmak, konfigürasyona göre yasaklanmıştır (bkz. AllowNoPassword). Parola olmadan phpMyAdmin'e girmek için ne yapmalıyım? Teşekkürler


11
2018-05-21 13:29


Menşei




Cevaplar:


AllowNoPassword seçeneğini /etc/phpmyadmin/config.inc.php dosyasında açabilirsiniz.

Config.inc.php dosyasını düzenleyin, bu satırı arayın ve uncomment:

// $ cfg ['Sunucular'] [$ i] ['AllowNoPassword'] = TRUE;

Daha sonra PhpMyAdmin'e şifre olmadan erişebilirsiniz.


20
2018-05-21 13:40



Bu komut yardımcı olabilir (Ubuntu 10.04 üzerinde test edilmiştir): sed '/ ^. * AllowNoPassword. * / S / \ / \ ///' /etc/phpmyadmin/config.inc.php> /tmp/conf.tmp && mv / tmp / conf.tmp /etc/phpmyadmin/config.inc.php - Netum
Teşekkürler, bunu yaptıktan sonra apache ve mysql'i yeniden başlatıyorum ama yine de şunu alıyorum: Parola olmadan oturum açma yapılandırmayla yasaklandı (bkz. AllowNoPassword) - Yosef
Ayrıca çalıştırıyorum: sudo sed '/ ^. * AllowNoPassword. * / S / \ / \ ///' /etc/phpmyadmin/config.inc.php> /tmp/conf.tmp && mv /tmp/conf.tmp / etc / phpmyadmin / config.inc.php ama alacağım: mv: üzerine yazmaya çalış /etc/phpmyadmin/config.inc.php', overriding mode 0644 (rw-r--r--)? y mv: cannot move /tmp/conf.tmp 'to /etc/phpmyadmin/config.inc.php': İzin reddedildi - Yosef
Komutu çalıştırmadan önce root almaya çalışın. Yürüt: sudo -s ve sonra sed komutu. Son olarak, izinleri atayın: chmod 640 /etc/phpmyadmin/config.inc.php && chown root: www-data /etc/phpmyadmin/config.inc.php - Netum
Bu çözümün Ubuntu 14.04'te artık işe yaramadığına inanmıyorum. Ben düzenledim /etc/phpymyadmin/config.inc.phpBu satırı rahatsız etmemek / etkinleştirmek için sudo /etc/init.d/apache2 restartWeb sitesini yenileyin, root ile giriş yapın ve şifre ile giriş yapın ve AllowNoPassword hata oluşmaya devam ediyor. - bafromca


İşte bu problemi çözmeye çalışmaktan fark ettim. neler yaşadım:

  1. $ Cfg ['Servers'] [$ i] ['AllowNoPassword'] = TRUE;
  2. Phpmyadmin'e gidiyorum ve şifre olmadan giriş yaptım. Sorun yok

Sonra apache'yi farklı bir kullanıcı ile www-data'dan çalıştırmak istedim.

  • / Etc / apache2 / eenvvars'a gidiyorum ve ihracatı düzenliyorum APACHE_RUN_USER = myuser ve export APACHE_RUN_GROUP = myuser

Apache2'yi yeniden başlatıyorum ve phpmyadmin'e parola olmadan giriş yapmaya çalıştığımda, daha önce de belirttiğim gibi, bana olay yerine izin vermiyor, $ cfg ['Servers'] [$ i] ['AllowNoPassword'] = TRUE.

Çözmek için

  • / Etc / phpmyadmin / adresine gidiyorum
  • izni kontrol et (ls-l'yi çalıştır)
  • Kök olduğunu fark ettim: config-db.php ve config.inc.php için www-data
  • Sudo chown root'u çalıştırıyorum: myuser
  • Apache'yi yeniden başlat
  • Sonra phpmyadmin'e git ve passowrd ile giriş yap.

Eğer apache'yi www-data'dan başka biriyle çalıştırıyorsanız (yani sizde) ve config.inc.php ve config-db.php'niz www-data'ya aitse, phpmyadmin


3
2017-07-27 23:47





Yukarıda belirtilen dosyaya (etc / phpmyadmin / config.inc.php.) erişmek ve aynı zamanda bu dosyayı düzenlemeden önce apcaha'yı durdurmak için Sudo'yu kullanın

// $ cfg ['Sunucular'] [$ i] ['AllowNoPassword'] = TRUE;

başka bir şekilde güncellemenize izin vermeyecektir. Apka durdurmak için komut

sudo /etc/init.d/apache2 durağı

umarım işe yaramasına yardımcı olur


2
2018-03-01 07:23





Açık phpmyadmin yapılandırma dosyası

sudo nano /etc/phpmyadmin/config.inc.php

/* Uncomment the following to enable logging in to passwordless accounts,
     * after taking note of the associated security risks. */
     $cfg['Servers'][$i]['AllowNoPassword'] = TRUE;

0
2017-07-27 08:38