Soru Dell OpenManage Sunucu Yöneticisi - depolama aygıtlarını göstermiyor


Dell PowerEdge R200 üzerinde CentOS 5 çalıştırıyorum. Makinede bulunan HDD'leri (x2 250GB RAID1) izlemek ve herhangi bir sorun veya hata durumunda uyarmak için özellikle OpenManage Sunucu Yöneticisi'ni kurdum.

Ayrıca, makinenin SATA2 HDD'leri olan R200 olan SAS 5 / iR / 6 / iR Aygıt sürücüsünü de kurdum.

Ancak, depolama cihazlarını OMSA web arayüzünde gösteremiyorum. Cevabı başka hiçbir yerde bulamıyorum, bu yüzden sizden herhangi birinin aynı sorunu daha önce yaşadığını merak ediyorum.

Şimdiden teşekkür ederim,

Fiske.

::GÜNCELLEŞTİRME::

Aşağıda, David tarafından önerilen tüm hizmetler yeniden başlatıldığında, aşağıdakiler gerçekleşir:

[root@xx ~]# for i in dsm_om_shrsvc instsvcdrv dataeng dsm_om_connsvc ; do service $i stop  ; done
Shutting down DSM SA Shared Services:                      [  OK  ]

Stopping Systems Management Data Engine:
Stopping dsm_sa_snmp32d:                                   [  OK  ]
Stopping dsm_sa_eventmgr32d:                               [  OK  ]
Stopping dsm_sa_datamgr32d:                                [  OK  ]
Stopping Systems Management Device Drivers:
Stopping dell_rbu:                                         [  OK  ]
Stopping Systems Management Data Engine:
Stopping dsm_sa_snmp32d: Not started                       [FAILED]
Stopping dsm_sa_eventmgr32d: Not started                   [FAILED]
Stopping dsm_sa_datamgr32d: Not started                    [FAILED]
Shutting down DSM SA Connection Service:                   [  OK  ]

[root@xx ~]# for i in dsm_om_shrsvc instsvcdrv dataeng dsm_om_connsvc ; do service $i start ; done
Starting DSM SA Shared Services:                           [  OK  ]
Starting Systems Management Device Drivers:
Starting dell_rbu:                                         [  OK  ]
Starting ipmi driver: Already started                      [  OK  ]
Starting Systems Management Data Engine:
Starting dsm_sa_datamgr32d:                                [  OK  ]
Starting dsm_sa_eventmgr32d:                               [  OK  ]
Starting dsm_sa_snmp32d:                                   [  OK  ]
Starting DSM SA Connection Service:                        [  OK  ]

Gördüğünüz gibi dsm_sa_snmp32d, dsm_sa_eventmgr32d, dsm_sa_datamgr32d ilk etapta başlamamış ve tüm hizmetlere başladığımda başlıyorlar. Ancak durma döngüsünü tekrar çalıştırdığımda, zaten durduruldular.

:: GÜNCELLEME 2 :: Aslında, görünüşte durdurulan hizmetin hizmet durumuna göre, aslında çalışıyorlar, dolayısıyla yukarıdakiler alakalı olmayabilir.


7
2018-06-09 07:29


Menşei




Cevaplar:


Çözdüm sanırım. OMSA'yı kurarken, TÜM bileşenleri taktığınızdan emin olun, örn. devamındaki:

[x] Server Administrator CLI
[x] Server Administrator Web Server
[x] Storage Management

Depolama yönetimini yüklemeyi ihmal ederseniz, depolama cihazlarını yönetme şansınız yoktur :)

Şimdi sadece uyarıları bana e-postayla gönderebilir miyim öğrenmem gerek. Hepinize teşekkürler!

Fiske


3
2018-06-09 13:13



PERC sürücülerinin güncelliğini yitirmişseniz, aynı zamanda sizin için de Depolama seçeneğini kaldırın. - Zypher


Bu bana da oldu - fiziksel diskler üzerinde en son ürün yazılımı olduğunu kontrol edebilirsiniz. Bu sorunu güncellemek, tüm saçlarımı çektikten ve Dell'i aradıktan sonra sorunu çözdü.


2
2018-06-17 13:45





Evet, bazen OMSA düzgün başlamıyor. Neden olduğunu anlayamadım.

Benim yöntemim bu betiği root kullanıcısına açık tutmaktır, eğer çalıştırırsanız (genellikle) OMSA parçaları çalışır ve istediğiniz bilgiyi alabilirsiniz:

#!/bin/bash

for i in dsm_om_shrsvc instsvcdrv dataeng dsm_om_connsvc ; do service $i stop  ; done
sleep 5
for i in dsm_om_shrsvc instsvcdrv dataeng dsm_om_connsvc ; do service $i start ; done

1
2018-06-09 09:12



Çok teşekkür ederim :) Tüm servisleri yeniden başlattım ve depolama cihazları hala görüntülenmiyor. Bunun kesinlikle SAS 5 / iR / 6 / iR cihazlarıyla çalışıp çalışmadığını biliyor musunuz? Teşekkürler - user8548